Skip to main content
Version: 3.x

deprecated

Marks an element of a GraphQL schema as no longer supported.

directive @deprecated(
reason: String = "No longer supported"
)

Arguments

reason (String)

Explains why this element was deprecated, usually also including a suggestion for how to access supported similar data. Formatted using the Markdown syntax, as specified by CommonMark.